Knowledgebase
Orders Importing as Invoices Instead of as Sales Receipts
Posted by Adam Liberman on 05 April 2011 10:10 PM

Problem:
Orders are importing as Invoices instead of as Sales Receipts.

Cause:
Either payment modules are not configured properly, or the QBI database tables need to be updated to work with your payment module.

Solution:

First check the following:

1) In QBI, go to Configure>Options and make sure that "Import paid orders as:" is set to "Sales Receipts".

2) Go to Match>Payments and make sure that the payment module you are using is matched to a Quickbooks payment method.

3) Go to Set Up>Payments and make sure that the Quickbooks payment method you have matched to is set to "Paid Online".

Try creating the iif file again. If there is still a problem, the payment module may not be listed in QBI, or may be listed slightly differently than it needs to be.

To correct this yourself, you will need to access your store database using PHPMyAdmin (usually from your website control panel) and modify some data. If you do not know how to modify the MySQL data, submit a support ticket and we will fix it for you.

To edit the payment module information in QBI:

1) Open PHPMyAdmin and look at your store database.

2) Browse your "orders" table. Reverse sort it by order_id, and look at the fields "payment_method" and "payment_module_code" for a sample order that is not importing as a Sales Receipt.

3) In the "qbi_paycart" table, make sure you have a row where:

"qbi_paycart_text" = the "payment_method" found in the orders table, and

"qbi_paycart_mod" = the "payment_module_code" found in the orders table.

If not, modify a row or add a new one with the correct data.

4) Go to Match>Payments and make sure that this entry is matched. If not, match it.

5) Go to Set Up>Payments and make sure that the Quickbooks payment method you matched to is set to "Paid Online".

The orders should now be exported as Sales Receipts. If you have multiple payment modules that are causing this problem, you may need to update them as well.

Versions:
3.50 and higher

(58 vote(s))
Helpful
Not helpful