Knowledgebase
Checking for the ionCube Loader on the server
Posted by Adam Liberman on 07 September 2013 12:08 PM

QBI is encoded and requires that your web server has the ionCube loader installed. 95%+ of servers already have it. However, in some cases, yours may not have it installed, or may have an old version. In this case, you simply need to ask your web host to install or upgrade the ionCube loader.

To verify if the ionCube loader is properly installed, copy the file below to your server and then go to it in your web browser. If the loader is installed, you will see a message confirming proper installation. If the version is too old, the message will ask you to upgrade your loader. If the page is blank or you receive a server error, then the ionCube loader is not installed or not installed properly.

If you ask your web host to install or upgrade the ionCube loader, give them the URL where you've placed the test page on your server. That way, after they do it, they can verify that the job was done correctly.

QBI versions < 3.89, and 3.89 delivered through May 31, 2013 require ionCube loader version 3.1 or higher.

QBI versions 3.89 through 3.91 delivered June 1, 2013 through June 19, 2015 require ionCube loader version 4.0 or higher.

QBI version 3.91 delivered June 20, 2015 or later requires ionCube loader version 4.4 or higher (and PHP 5.4 or higher).

QBI version 3.91 delivered July 10, 2016 or later requires ionCube loader version 5.0 or higher (and PHP 5.6 or higher).



Attachments 
 
 qbi-ioncube-loader-test.php (3.07 KB)
(1 vote(s))
Helpful
Not helpful